125cc Sportsbikes Forum: Gilera Sc No Spark - 125cc Sportsbikes Forum

Jump to content


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Gilera Sc No Spark

#1 User is offline   grant1312 

  • 125cc Sportsbikes Novice
  • Pip
  • Group: Members
  • Posts: 3
  • Joined: 24-April 17

Posted 24 April 2017 - 06:27 PM

Hi everyone,

i got a sc that needed maintenance work done did all that then the starter motor decided to die so replaced that and it started fine was running for about 5-10 mins then suddenly died, checked for spark and had none since then i have replaced the coil, lead, plug cap and plug still no spark.

anyone have a rough idea where to look next?

thanks,

Grant

Remove Advertisements User is offline Advertisements

  • 125CCSportsBikes.com



#2 User is offline   grant1312 

  • 125cc Sportsbikes Novice
  • Pip
  • Group: Members
  • Posts: 3
  • Joined: 24-April 17

Posted 24 April 2017 - 07:25 PM

View Postgrant1312, on 24 April 2017 - 06:27 PM, said:

Hi everyone,

i got a 2007 2t sc that needed maintenance work done did all that then the starter motor decided to die so replaced that and it started fine was running for about 5-10 mins then suddenly died, checked for spark and had none since then i have replaced the coil, lead, plug cap and plug still no spark.

anyone have a rough idea where to look next?

thanks,

Grant


#3 User is offline   RBmito 

  • 125cc Sportsbikes Team Manager
  • Group: Moderators
  • Posts: 2,888
  • Joined: 19-July 10
  • Location:Colchester, Essex

Posted 24 April 2017 - 08:51 PM

don't know anything about gilera's/derbi's Side stand switch, if they have one? The kill switch on the hbar control....I take it that's on. Wiring damaged somewhere? Have a look at a wiring diagram if you can & then you can do some proper fault finding... it might be something simple :thumbsup:

This post has been edited by RBmito: 24 April 2017 - 09:21 PM


#4 User is offline   grant1312 

  • 125cc Sportsbikes Novice
  • Pip
  • Group: Members
  • Posts: 3
  • Joined: 24-April 17

Posted 24 April 2017 - 09:04 PM

no side stand switch but was wondering about the kill switch just got no idea how to test it :ponder: , just a pain it cant have every problem at once its fix problem then i will get another one its like having a hypochondriac bike.

#5 User is offline   RBmito 

  • 125cc Sportsbikes Team Manager
  • Group: Moderators
  • Posts: 2,888
  • Joined: 19-July 10
  • Location:Colchester, Essex

Posted 24 April 2017 - 09:25 PM

The coil connection is usually the same as the kill switch feed, & said kill switch usually grounds the feed to kill the spark. It's easy to check with a multimeter.It will be process of elimination until you find the faulty culprit I'm afraid.Good old Italian electrics .lol.

This post has been edited by RBmito: 24 April 2017 - 09:27 PM


#6 User is offline   Cagiva4ever 

  • 125cc Sportsbikes Team Manager
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 2,820
  • Joined: 07-January 04
  • Location:Finland

Posted 30 April 2017 - 02:12 PM

actually it has 99% japanise made electrics, Due the fact having Yamaha 3BN engine etc in it, being DTR TDR TZR engine 3BN base.

i have non-complite GPR125 2T my self... same as 2T SC just re-badged re-named.

what i have read from experienced Yamaha mechanic, is that 3BN stator is very delicate for having Good battery. do not ask how, but apparently poor battery can ruin stator and cause intermittent or and missing sparg.
last-5 3BN's with broken stator he has fixed, all 5 have had dead shorted battery.

i said do not ask how, as its still basic ac-cdi and separate pick-up coil ,and reg-rec charging circuit basically has nothing to do with ignition circuit...as iirc 3BN has battery run lights, not so called "magneto run lights" so to speak...

ive not yet gone deep into my 3BN project..........

anyway 3BN TDR etc book's W.S.M's have ign parts Ohms values, get them read them and do measures. i do not have my notes in hand to write them here.....

you really need to Multimeter measure each component. everything else is basically useless effort...if TRU issue is failed ign Component(s)

Check also W-D-Key at FlyWheel after Multimeter work....

This post has been edited by Cagiva4ever: 30 April 2017 - 02:17 PM


Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users