125cc Sportsbikes Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hi all
I'm new to forum and in need of some advice, my headlights stopped working after being out at work all night in quite heavy rain and when riding home in the morning I noticed the dipped beam wasn't working and when I tried the high beam they weren't working either and the high beam light on the dash isn't coming on either.
I have checked the fuses and they are OK just wondering if anyone has had a similar problem before and the best place to start coz I thought it could be that water got in the wires and shorted it but that would of blown the fuse surly?
all other lights and indicators work and all dash lights work except the high beam indication light so was wondering if the switch gear failing somewhere would take out the headlights and dash high beam light or where would be a good place to start diagnosis
any help would be greatly appreciated.
 

·
Registered
Joined
·
3 Posts
Also check the blue relay tucked up between the lights and clipped to the front headlight bracket, this is the headlight cut out relay that cuts power to the main lights when the starter button is pressed. If this has gone U/S then it just wont give power to the headlight circuit.
 

·
Registered
Joined
·
3 Posts
hi all
I'm new to forum and in need of some advice, my headlights stopped working after being out at work all night in quite heavy rain and when riding home in the morning I noticed the dipped beam wasn't working and when I tried the high beam they weren't working either and the high beam light on the dash isn't coming on either.
I have checked the fuses and they are OK just wondering if anyone has had a similar problem before and the best place to start coz I thought it could be that water got in the wires and shorted it but that would of blown the fuse surly?
all other lights and indicators work and all dash lights work except the high beam indication light so was wondering if the switch gear failing somewhere would take out the headlights and dash high beam light or where would be a good place to start diagnosis
any help would be greatly appreciated.
I'm currently having the same problem but
Also check the blue relay tucked up between the lights and clipped to the front headlight bracket, this is the headlight cut out relay that cuts power to the main lights when the starter button is pressed. If this has gone U/S then it just wont give power to the headlight circuit.
I'm trying to find the relay you said but can't find it, there is only the indicator relay
 
1 - 4 of 4 Posts
Top