125cc Sportsbikes Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
Hi Every-one,I have a problem with my power valve!!The cables are 1 to 1 and 2 to 2,The control box is fitted,And the servo is in position.When turned on it goes through its cycle!!!
Then when i start it it goes to position 1 marked on the pv housing.When i rev it up it just stays there does not move at all,Are the cables right?Or how high should you rev the bike
to get the pv to move.It pulls away slow but once going it runs ok through the gears up until about 7000 revs then it starts spluttering.Im used to my yzfr125 and notice a big difference.
Got 83mph out of my yzfr last week so not bad standard,Beats the tzr at the moment.But i dont want it to lol !!!
Thanks for looking!!!!
 

·
Registered
Joined
·
54 Posts
If it goes thru it's cleaning cycle. The servo should be fine. I suspect it might be the black and white cable loose or improperly connected. Check all black and yellow wire connections as that's the wire which tell the Cdi when to open. The valve opens at around 7k rpm.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #3 ·
If it goes thru it's cleaning cycle. The servo should be fine. I suspect it might be the black and white cable loose or improperly connected. Check all black and yellow wire connections as that's the wire which tell the Cdi when to open. The valve opens at around 7k rpm.
Thank-you i will check all those wires tomorrow,Thanks for looking!!!
 

·
TZR: Smokey... Not Burned
Joined
·
3,522 Posts
if the control box is dodgy, the pv will still do its cleaning cycle. but nothing else. i may suspect that if all the connections are good, it may be a dodgy contol box.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #5 ·
if the control box is dodgy, the pv will still do its cleaning cycle. but nothing else. i may suspect that if all the connections are good, it may be a dodgy contol box.
Thanks Tony,I have checked the wires and all are ok!!! I have had messages from that person on ebay who modifies them and he said he will fix and put the mods on it!!
All i have to do is send it to Athens lol,But he said it does not sound like the control box.Thanks for looking...
 

·
TZR: Smokey... Not Burned
Joined
·
3,522 Posts
other than individually checking the sence wire coming into the control box and ensuring that is works, the other may be to swap the servo, and the control box 1 by 1 for ones that are known to work 100%.
 
1 - 7 of 7 Posts
Top