125cc Sportsbikes Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hi, I want to take my screen right off for a bit of a clean but just can't get the thing off. There's two screws either sides which I've unscrewed but I reckon there is another one at the base of the screen in the centre that can't be seen. Anyone have a clue as to how to get to this one? Cheers ftw
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
Hmm, maybe, I've loosened everything around it and it just won't budge. Some aftermarket screens looks like they have a hole at the base so it would make sense to look for another screw fixing. I don't want to force it though...

Hey Numpty, when you say 4 screws, do you mean the four I have removed, 2 from each side of the screen, the triangle bit covers the base of the screen so if I could remove that...
 

·
Registered
Joined
·
1,078 Posts
I've never really looked but I'd imagine it would just slide upwards and out. I just had a quick look in the manual and I couldnt see anything. Are there any instructions with your new screen?
 

·
CBR125 Section SuperMod!
Joined
·
6,698 Posts
2 either side then 1 under that triangle bit
 

·
Registered
Joined
·
205 Posts
Theres 4 at the top that you can see, then theres one at the bottom, you have to take the clocks off to get at it. Its a pretty fiddly screw to get at and try to use a magnatised screwdriver if you have one as the screw can be hard to get out after its unscrewed. Then its still pretty hard to get the screen off and you have to sort of shake it about a bit.
 

·
CBR125 Section SuperMod!
Joined
·
6,698 Posts
why do people think taking clocks off is a big job infill panels off 2 bolts and jobs a good un
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #15 ·
why do people think taking clocks off is a big job infill panels off 2 bolts and jobs a good un
Right, I got the screen on, everything done up and now my speedo don't work! When I took off the clocks I unscrewed the speedo and removed the wire so the two were totally separate, then I just stuck the wire in the hole and did up the bolt, am I doing anything wrong?

Cheers...
 

·
Registered
Joined
·
205 Posts
Just make sure its tightened up as if its not tightened the flat bits wont go into the slots! How did you eventually get the screen off after you got all teh screws out? Oh and are your lights on the clocks still working(neutral light etc) as it could be due to a cable coming lose and the clocks not getting power thats what happened to me.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top